Archivo de la etiqueta: Modem3G

Enviar SMS desde la linea de comando

Como enviar mensajes de texto desde la terminal con el modem 3g ZTE MF636 en Fedora Linux? Como activar un plan prepago de tu modem3g desde la linea de comando?

Yo necesito enviar un mensaje para activar mi plan prepago de movistar (Nicaaragua), luego esperar la respuesta sobre las opciones de tiempo de conexión, contestar con un número de opción y esperar por la confirmación. Poner el SIM card en un telefono para hacer esto y luego ponerlo en el modem es tedioso. Peor aun sería cargar Windows con la suite de la compañía de celular para enviar el mensaje y luego regresar a linux. Cosa que a final no puedo hacer porque no tengo Windows en mi laptop.

Para mi lo ideal era usar una herramienta con interfase gráfica como gnome-phone-manager. En verdad me funcionó para enviar mensajes, luego hubo un conflicto de versión de GTK y ahora no logro que se conecte a un puerto serial, siempre busca un puerto bluetooth. En realidad gnome-phone-manager es una interfase gráfica para gnokii que es el verdadero programa que administra la comunicación con el modem 3g.

Así que lo primero es instalar gnokii y lo podemos hacer desde la terminal.

su -c “yum install gnokii”

Yo uso la sintaxis de fedora. Para usar sudo en fedora deben configurarlo. Y si usan otra distro deben ver el comando de instalación específico para su distro. Igual podemos buscar el paquete para su instalación desde la administración de software.

Lo siguiente es configurar gnokii. Para ellos creamos un archivo llamado .gnokiirc y lo ponemos en nuestra carpeta de usuario.

/home/mi_nombre/.gnokiirc

Donde mi_nombre es el nombre del usuario. El contenido del archivo es simple:

[global]
port=/dev/ttyUSB2
model=AT
connection=serial

Nuestro usuario no tiene permisos de acceso al puerto serial que hemos utilizado. Así que debemos incluir a nuestro usuario en el grupo de dialout.

Desde la linea de comando podemos usar el siguiente comando:

su -c “usermod -a -G dialout mi_nombre”

De nuevo donde mi_nombre es el nombre del usuario. El comando anterior debe ser igual para todas las distribuciones de linux. Otra alternativa es instalar el paquete system-config-users que es una interfase gráfica para administrar los usuarios con más detalles, como por ejemplo hacer un check en el grupo que queremos que nuestro usuario pertenezca. Esto lo encontramos como la aplicación de “usuarios y grupos”. Desde los ajustes de sistema en Gnome Shell solo veremos unas opciones limitadas para administrar usuarios.

Ahora podemos conectar el modem y esperar que este listo. Esto a simple vista se puede verificar con la luz azul que parpadea en el modem ZTE MF636.

La otra alternativa es usar el comando dmesg en la terminal que nos brinda al final aproximadamente las siguientes lineas

[ 824.501063] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
[ 824.507774] usbcore: registered new interface driver option
[ 824.507783] option: v0.7.2:USB Driver for GSM modems
[ 829.753101] scsi 5:0:0:0: Direct-Access ZTE MMC Storage 2.31 PQ: 0 ANSI: 2
[ 829.758421] sd 5:0:0:0: Attached scsi generic sg1 type 0
[ 829.766896] sd 5:0:0:0: [sdb] Attached SCSI removable disk

A este punto podemos probar que todo esta bien con el siguiente comando:

gnokii – -identify

la respuesta deberia ser a como sigue:

GNOKII Version 0.6.31
IMEI : 352847029322631
Manufacturer : ZTE INCORPORATED
No flags section in the config file.
Model : MF636
Product name : MF636
Revision : BD_LATMOVP673M2V1.0

Yo debo enviar la palabra ACTIVAME al número 2266, el comando es a como sigue:

echo “activame” | gnokii – -sendsms 2266

La parte dificil es que el modem ZTE MF636 no es compatible con la opción de espera para capturar el mensaje. Asi que debemos consultar el contenido de memoria del modem con el siguiente comando:

gnokii – -showsmsfolderstatus

Lo que nos brinda el siguiente reporte

GNOKII Version 0.6.31
No. Name Id #Msg
========================================================
0 Internal memory ME 0
1 Combined ME and SIM phonebook MT 0
2 SIM card SM 7
3 SMS Status Reports SR 0

Podemos ver que los mensajes se almacenan en la SIM card y que esa memoria es SM. En este caso hay 7 mensajes, en linux eso significa mesnajes del 0 al 6. Si quiero ver los mensajes el comando será:

gnokii – -getsms SM 0 6

puedo consultar solo un mensaje, le doy la posición de dicho mensaje sin especificar inicio y fin, por ejemplo el último mensaje será:

gnokii – -getsms SM 6

lo que me da como resultado algo asi:

6. Inbox Message (Unread)
Date/time: 13/09/2013 21:50:23 -0600
Sender: 2266 Msg Center: +5026099948
Text:
Envia 1 para contratar 2hr de navegacion por CS15, 2 para contratar 12hrs por CS50, 3 para 30min por CS10, 4 para 24hrs por CS90 o 5 para 3 Dias por CS150

Ahora podría repetir los pasos y enviar la respuesta, por ejemplo opción número 1 con el siguiente comando:

echo “1” | gnokii – -sendsms 2266

Y solo me queda esperar la confirmación, que puedo consultar a como he mostrado anteriormente.

Algunas cosas adicionales con el manejo de los mensajes podría ser guardar los mensajes a un archivo de texto

gnokii – -getsms SM 0 6 -f archivo.txt

Donde archivo.txt es el nombre de archivo de su elección.

Tambien pueden borrar los mensajes almacenados en el SIM card. Supongamos que queremos respaldar a nuestra maquina los mensajes y luego borrarlos:

gnokii – -getsms SM 0 6 -f archivo.txt -d

Algo a tener en cuenta es que cuando se conectan a la internet por el modem3g, ya no podrán hacer uso de las opciones de envío y recepción de mensajes.

Espero que esto sea de utilidad para algunas personas con planes de prepago en modem 3g. Sin embargo yo solo tengo el modem que describo. Así que no puedo asegurar como funcionará con otros modem3g, sin embargo esto les podrá servir de guía.

Quiero agradecer a Spot quien me ayudo a encontrar muchos de los detalles de gnokii en particular la siguiente referencia: http://wiki.gnokii.org/index.php/SMS_options (la página esta en inglés)

Segundo día sin mi conexión de cable.

Ya llevo 24 horas sin internet. Segun la promesa del soporte técnico de Claro, a esta hora ya deberian haber resuleto mi problema. Mi primer temor era que iban a visitar mi casa cuando yo no estuviera y entonces todo iba a complicarse. Resulta que yo fui muy optimista y no vinieron.

Así que volví a llamar, esta vez debor econocer que fueron más amables… excesivamente amables… exasperantemente amables… es absurdo que te pidan disculpa por cada momento de espera, yo entiendo que estan consultando cosas y si cada vez que hacen una pausa se van a disculpar la llamada realmente se prolonga. En fin, la persona de reclamos esta vez me brindó mi número de contrato y me pasó a soporte técnico. Me alegró mucho que me saliera una mujer, las mujeres son más eficientes, y esta vez no fue una excepción. Como me molesta un tipo con pretenciones de que se las sabe y a final nada.

De nuevo con la repetición exasperante de disculpas, me pregunto si en la pantalla me pedia usuario y contraseña. Yo pense que esto era un paso adelante. Ayer no sabian nada y esta mujer si sabe de mi problema.

Me dio un usuario y contraseña, pero no funcionó. Luego con un mar de disculpas me dice que lo que sucede es que estan en mantenimiento. Como que mantenimiento? … Por qué no me dijeron eso ayer? Otro mar de disculpas y la promesa de que va a pasar los datos a su supervisor. Para que quiero que le pase los datos a su supervisor, yo lo que quiero es internet !! Todo lo que me había hecho pensar de positivo esa mujer ahora es negativo, porque la impresión que me da es que me estan “cuentiando”.

Asi que otro día más a navegar usando mi modem3g Movistar.

Ayer puse un link en el wall de Facebook de Claro, el cual dirigia al post de ayer. No pasaron ni dos minutos en borralo. Parece que piensan que si no hay comentarios negativos la gente realmente va a creer que dan buen servicio. me retaron a poner un post y hacer un screen shot… asi que este segundo post incluirá ese ejercicio. Mi apuesta es que van a borrar mi post sin leerlo… esperen pronto la captura de pantalla.

Modem3G como conexión de back-up

En un tiempo, según mi opión individual, sin ningún tipo de estadística, IBW era el mejor servicio de Internet. Claro lo compró y por arte de magia dejo de servir. Tenia un servicio de conexión inalambrica de 1Mb y de la noche a la mañana era mas rápida la conexión de Cable de 256kb que tenia de Cablenet/Estesa. A final descontinue el servicio. Un mes después me llegaron a cambiar la antena. Cambiarla!? Yo espero que se la lleven, yo ya no pago ese servicio. El técnico se fue porque su orden era de solo para cambio. Volvieron como un mes después ya a retirar la antena. Era increible tener que desconectar y conectar la fuente de poder de ese equipo tres, cuatro y hasta cinco veces al día.

Por otro lado Cablenet/Estesa se comnvirtió en el mejor proveedor de Internet. De nuevo según mi opinión individual y sin ningún tipo de estadistica. Cuando Claro compro Cablenet/Estesa, yo pense que se había acabado el internet en Nicaragua. Al menos en lo que se refiere a servicio domiciliar. Para mi sorpresa el cablemodem en mi casa siguió funcionando. Luego iniciaron algunos problemas, como que la factura la dejaban en la casa de mi papá, y por mucho que solicité que la dejaran en mi oficina, lo único que logré fue que fuera una sorpresa dode iba a aparecer la factura. Y en más de una ocación me salté un pago por ese desorden y me quede sin servicio. La reconexión era algo absurdo, si no tenía el número de contrato, no puedo pagar en una oficina de Claro, tenía que ir a Estesa. Acaso no la compraron?

Durante el día yo trabajo, es de noche cuando uso internet en la casa. Todo estaba bien y hace unos minutos dejo de funcionar. Que fue lo que me salió en el browser ?

Por qué me envia esa pantalla en lugar de permitirme navegar?

Llamé al servicio técnico, de nuevo sin número de contrato, no hay soporte. Mi archivo lo manejo en la oficina. Luego de lograr hablar con alguien me dice que me pasará con soporte técnico y que le dará mi número de contrato… Mentira. Debo iniciar de cero con soporte técnico. Dice que va a resetear el modem desde allá … luego me dice que lo haga yo oprimiendo el reset… nada surge efecto.

“Claro” que “tuitié” sobre esto. Pero un tuitazo no es suficiente.

Que más nos falta? Que los datos de APN de Claro estan mal en linux? Ya hice un post sobre eso!. No faltaba más que todos mis ejemplos de modem3g son sobre Movistar …

Me siento feliz de tener un modem3G como back up de mi conexión y en gran medida porque es de Movistar.

Conexión modem3G con Claro en Nicaragua

NOTA IMPORTANTE:

Si usted tienen Fedora 16 actualizado,los datos de conexión ya estan correctos.

Si usted tiene un modem3G movistar… esto no le sirve para nada.

Esto solo aplica para Nicaragua. Si usted usa Claro en otro país esto no le sirve para nada.

Varias personas han tenido problema con la conexión de Claro usando modem3G en Linux. Esto no es un problema de Linux. No puedo asignar la culpa puesto que no tengo información. Parece un problema de comunicación entre alguien de Claro y el mundo Linux. La cosa es que los datos de conexión están mal dentro del modem, los reporta equivocadamente y hay que corregirlos para que funcione el modem3G.

Los datos estan el blog de Marconi Poveda, pero parece que esto es algo del otro mundo, asi que aqui va paso a paso.

El primer paso es hacer click derecho en el icono del NetworkManager, eso abre el siguiente menú.

Ahi se da click en editar conexiones, lo que nos abre una ventana con información de las conexiones. Seleccionamos la pestaña de conexiones móviles de banda ancha. Luego seleccionamos la conexión de Claro y le damos al botón editar.

Cuando se abra la ventana de editar conexión se va a ver asi…

Y esta mal. Asi que deben editar los campos para que este así…

Le dan aplicar a la ventana de las propiedades de la conexión de claro. Luego le dan click al botón de cerrar de Editar Conexiones de Red.

Y listo… ahora un click derecho en el icono de network manager y otro click derecho en su conexión de claro.

Si tienen dudas de como conectar tengo un post viejo de como es que funciona esto. Lo unico que ahora ya no sale el icono en el escritorio… solo hay que saltar ese paso.

Espero que sea útil.

Wifi: La frontera final

Desde hace tiempo yo estoy confiado que yo enchufo algo a mi computadora con Linux y funciona. Sencillo y simple. pero últimamente las tarjetas de redes inalambricas me han dado mucho que hacer. Inicialmente fue mi laptop nueva con una tarjeta realtek. Segun entiendo lo que sucede es que se ha ido evolucionando de chips, y antes teniamos tarjetas “a” de 11Mbps, luego “b” que no recuerdo que era… luego vinieron las “g” de 54Mbps y ahora estan entrando las tarjetas “N”

Pues yo compre una tarjeta PCI sin pensarlo mucho… una D-Link N150 Modelo DWA-525 y resulta ser que Fedora “sabe” que esta ahi, pero no puede activarla. Usando el comando lspci me dice que es un chip Ralink 3062. Revisando en la web, me entero que ndiswraper no funciona si la tarjeta es detectada por lspci.

Luego de tener serios problemas para encontrar algo, me voy de impulso y compro otra tarjeta. Nexxt Ion300 Modelo APLDT300U1. Segun yo, siendo dos tarjetas distintas deberian ser muy distintas por dentro (Fail!). Esta tarjeta segun lpci tiene un chip Ralink 3060.

No muy feliz, me puse a buscar en otra tienda y me encontre una tarjeta Linksys Modelo WMP600N. Esta vez le pregunte a “San” Google y me dijo que el chip era Ralink 2860. Así que ya no hice ninguna compra impulsiva.

Ni modo, tuve que profundizar más y seguir un tutorial que me resulto muy bueno.

http://www.hyperborea.org/journal/2010/08/wifi-ralink-3062/

En ese link además me gusta que expresa que configurar tarjetas wifi aun no es un terreno sólido. me gusta, que en lugar de dar solo los pasos, primero comenta el proceso.

Al final esta tarjeta esta en la casa de un amigo que esta usando una computadora con Fedora. Conecta un modem3G y usa la terjeta wifi para compartir la señal con las laptos de su casa.

Problemas con Modem3G ZTE MF636 y Fedora 12

Hace algun tiempo publique un post sobre lo bonito que estaba Fedora 12 y el modem3G, luego publique otro post donde exponia una solucion a un problema que he encontrado. Ahora tengo un par de cosas más que agregar, dos problemas… uno de ellos con solución.

El primer problema que me encontre es que luego de viajar mi modem3G no funciona. Una cosa no esta directamente relacionada con la otra. Pero me tomo tiempo entre la última vez que use mi modem3G y las siguiente vez porque estuve viajando. En medio de eso hice actualizaciones de mi laptop. Yo siempre hago las actualizaciones, será momento de cambiar de hábitos?

La cosa es que traté usando los kernel viejos que tengo en el menu del grub y nada. Tambien probé con un disco de Fedora 13 Alfa y tampoco funcionó. Revertí los cambios que habia echo el en post de troubleshooting, y nada. Me dice:

usb 1-3: new high speed USB device using ehci_hcd and address 8
usb 1-3: New USB device found, idVendor=19d2, idProduct=2000
usb 1-3: New USB device strings: Mfr=3, Product=2, SerialNumber=4
usb 1-3: Product: ZTE CDMA Technologies MSM
usb 1-3: Manufacturer: ZTE,Incorporated
usb 1-3: SerialNumber: 1234567890ABCDEF
usb 1-3: configuration #1 chosen from 1 choice
scsi8 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 8
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 8:0:0:0: CD-ROM            ZTE      USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 2
sr1: scsi-1 drive
sr 8:0:0:0: Attached scsi CD-ROM sr1
sr 8:0:0:0: Attached scsi generic sg2 type 5

Pero no me aparece el icono en la pantalla y si le digo: “eject sr1” me dice que:

eject: unable to find or open device for: `sr1′

Escribi en Fedora Forum, pero aun no he tenido respuesta sobre esto.

La otra cosa que hice fue cargar un liveCD de Fedora 12. Total antes me habia funcionado bien. Resulta ser que me encontre otro problema al usar el liveCD. Este otro problema es distinto a lo que habia reportado anteriormente.

La situación es que cargo el liveCD (Gnome), conecto el modem, expulso el icono que aparece en el escritorio, espero por que el NetworkManager encuentre el modem3G, configuro la conexión, intenta conectarse y la conexión falla. Vuelvo a intenatr y el intento de conexión falla de inmediato.

La solución: Desconectar físicamente el modem3G, volverlo a conectar, expulsar el icono del escritorio, esperar a que NetworkManager detecte el modem3G, decirle que se conecte a la conexión por defecto (la que se habia configurado anteriormente).

Asi es como estoy escribiendo este post. Parece que hay un problema para reconectar, y entonces al fisicamente desconectar el modem y volverlo a conectar funciona. Lo mismo me pasa si pierdo la conexión. Debo fisicamente desconectar el modem3G y volverlo a conectar.

Parece un problema de comunicación… entre el equipo de NetworkManager y el equipo que maneja udev para el reconocimiento de hardware.

Tengo fe que pronto estará resuelto, cada nueva versión trae mejoras. Espero que los datos que aporto les sean útiles.

Trouble Shooting ZTE MF636 con Fedora

Este modem3G trae software incluido por el proveedor, cuando se conecta se reconoce como una unidad de disco compacto scsi. Tipicamente nos apareerá como sr1 y podremos darle la orden “eject” y de ahi poder usar el modem3g y el lector de memorias microSD.

icono en el escritorio

Pero que pasa sino vemos el icono del proveedor en nuestro escritorio?

Me ha pasado entres maquinas distintas. En la primera tiene una unidad DVD RW sata, asi que podía pensar que estaba en conflicto. Investigando el problema me encontre que al usar el comando “dmesg” se quedaba en espera de terminar el proceso:

usb 1-3: new high speed USB device using ehci_hcd and address 2
usb 1-3: New USB device found, idVendor=19d2, idProduct=2000
usb 1-3: New USB device strings: Mfr=3, Product=2, SerialNumber=4
usb 1-3: Product: ZTE CDMA Technologies MSM
usb 1-3: Manufacturer: ZTE,Incorporated
usb 1-3: SerialNumber: 1234567890ABCDEF
usb 1-3: configuration #1 chosen from 1 choice
Initializing USB Mass Storage driver…
scsi2 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning

Y hasta ahí se quedaba y no reportaba nada más. En otra maquina no habia unidad SATA, pero fedora 12 nombra mi unidad IDE como sr0. El reporte de “dmesg” pasaba de ese punto y tenia otras lineas adicionales a como sigue:

scsi2 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
USB Mass Storage support registered.
usb-storage: device scan complete
usb 1-3: reset high speed USB device using ehci_hcd and address 2
scsi 2:0:0:0: CD-ROM            ZTE      USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 2
sr1: scsi-1 drive
sr 2:0:0:0: Attached scsi CD-ROM sr1
sr 2:0:0:0: Attached scsi generic sg2 type 5

Pero nada del icono en la pantalla y revisando el directorio de dispositivos, no aparecia por ningun lugar  /dev/sr1

Asi que decidí reportar el bug. Resulta que NetworkManager es parte del proyecto Gnome y ellos usan bugzilla, pueden ver el ticket #603433

A final la culpa no es de NetworkManager, si no de udev, que controla la asignacion de los dispositivos de hardware. Lo bueno es que hay una forma de resolver esta situación.

Sin haber conectado el modem3G, hay que buscar el archivo /lib/udev/rules.d/61-option-modem-modeswitch.rules y editarlo. Al final del archivo hay dos lineas que no dicen ==”0af0″” las que muestro a continuación:

ATTRS{idVendor}==”12d1″, ATTRS{idProduct}==”1446″, RUN+=”modem-modeswitch -v 0x%s{idVendor} -p 0x%s{idProduct} -t option-zerocd”
ATTRS{idVendor}==”19d2″, ATTRS{idProduct}==”2000″, RUN+=”modem-modeswitch -v 0x%s{idVendor} -p 0x%s{idProduct} -t option-zerocd”

Hay que borrarlas esas dos lineas. Yo lo que hice fue hacer un respaldo del archivo en un directorio personal antes de editar ese archivo. Luego de eso se puede conectar el modem3G y seguir las instrucciones que presenté en mi post anterior.

Esta recomendación me funcionó en ambos escenarios y por ello la estoy compartiendo.

Modem ZTE MF636 en Fedora

En Fedora 10 use wvdial, en Fedora 11 usb_modeswitch y con Fedora 12 directo al NetworkManager. Todo inicia porque el modem3G se reconoce como un disco compacto sata, tipicamente sr1. Como una imagen vale más que mil palabras, vamos con las imagenes. Aqui vemos el dispositivo reconocido en el escritorio de trabajo:

icono en el escritorio

Paso 1: Expulsar
Expulsar el dispositivo

Paso 2: Iniciar una nueva conexión
Para esto debemos esperar un poco más de un minuto (si es un poco más de 60 segundos y parece una eternidad!)
Iniciar nueva red de banda ancha movil

Paso 3: Iniciar el asistente de configuracion Una vez hecha la configuracion la siguiente vez pasaremos al paso 10
Inicio de asistente de configuracion

Paso 4: Seleccionamos país
seleccionar pais

Paso 5: Seleccionar proveedor Yo no tengo un modem Claro, pero supongo que funciona igual
Escoger proveedor de Internet

Paso 6: Seleccionar Plan Bueno, para movistar no hay diferencia si tienen prepago o postpago. Solo hay un plan. Solo darle Forward.
seleccionar plan

Paso 7: Confirmar Esto me suena innecesario
confirmar datos

Paso 8: Introducir PIN No se si otros chips lo van a requerir. Lo bueno es que solo hay que ingresarlo una vez y ya queda almacenado.
ingresar PIN del chip del modem3g

Paso 9: Ingresar contraseña Esta es la contraseña para Movistar en Nicaragua, los usuarios se distinguen por el chip
ingresar contraseña
Listo! La conexión se establece automaticamente
estado de la conexion

Paso 10: Reconectar La siguiente vez que se conecte el modem, se podra reconectar asi… no es necesario volver a hacer toda la configuracion
reconexion

NetworkManager es la aplicación que hace todo esto posible. Es uno de los paquetes desarrollados por Fedora, pero que podran encontrar disponible en otras distros. Por ejemplo Ubuntu 9.10 usa este mismo paquete.
Acerca de NetworkManager

Bien, si no tienen Gnome, y estan usando KDE entonces deben instalar el paquete knetworkmanager y todo supone debe ser igual, al menos eso me ha dicho un feliz usuario luego de hacer la prueba.

Modem 3G en Fedora

Hace un par de meses se inicio un hilo sobre el uso de módem 3G en Linux, y por supuesto no tardo en hacerse también la pregunta sobre Fedora. Teniendo Internet en casa y en la oficina me resultaba como excesivo tener un dispositivo móvil de Internet. Pero para un geek siempre hay escusas, y los pizza bash son parte del cuento. Finalmente tengo en mis manos un juguete de esos, un ZTE MF636 y hay que echarlo a andar.

La primera aproximación fue con el wvdial, pero si bien ese paquete funciona, hay sus cosas de magia oculta. Mi amigo José Ernesto Dávila, ubuntero, me apunto hacia un post en su blog donde habla de como el hizo funcionar su módem realmente me resultó complicado y yo sinceramente ando con pereza. Así que en lugar de descargar y compilar decidí ver si el paquete esta en los repos… pues si, ahí estaba.

Así que con instalar usb_modeswitch tenemos un software que cuando detecta un aparato raro que dice ser un CD SCSI, lo cambia a un módem usb 3G. Nos ahorramos el comando “eject sr1”

Así que instalemos el programita:

yum install usb_modeswitch

Luego nos vamos a buscar nuestro módem en el archivo /etc/usb_modeswitch y des-comentamos la sección que hace referencia a nuestro módem En particular no hay ZTE MF636, así que yo use el MF626 y funciona.

Luego de eso, aplique el comando

usb_modeswitch

Le di unos segundos, y luego en el Network Manager aparece la opción para activar una conexión móvil de banda ancha.

Que me queda ahora? Ver como hacer para enviar mensajes de texto usando este aparato, porque como lo compre de pre-pago… necesito enviar un mensaje de “ACTIVAME” al 2266. Me gustan los puertos seriales y los comandos AT no me son extraños, pero de nuevo la pereza es imponente y quiero una solución más fácil y rápida que hacer el cambio de chip en mi celular.